网站 SSL 证书检测 PCI DSS 不合规的解决方法

2018年9月5日20:00:05 发表评论 302 阅读

SSL 相信不用多说,就是网站需要安装 SSL 证书后,才能够开始 HTTPS 协议的访问,可以提升网站数据传输的安全性。最近更换了服务器就提示 PCI DSS 不合规,因为 PCI DSS 是属于支付卡行业安全标准,并不涉及,所以也没有影响,但是觉得不好看,毕竟是红的,所以就找到了解决方法:

PCI DSS,全称 Payment Card Industry Data Security Standard,第三方支付行业数据安全标准,是由 PCI 安全标准委员会制定,力在使国际上采用一致的数据安全措施。早在去年 6 月 30 号 PCI 安全标准委员会官方发表博文将于 2018 年 6 月 30 号(最晚),也就是上月月底禁用早期 SSL/TLS,并实施更安全的加密协议(TLS v1.1 或更高版本,强烈建议使用 TLS v1.2)以满足 PCI 数据安全标准的要求,从而保护支付数据。

通过了解,我们知道这是安全性要求升级了,如果原有站点没有禁用 TLS1.0 就将被提示不合规。

由于子凡的服务器使用的 NGINX 服务器环境,所以在对于网站的配置文件中删除 TLSv1 就搞定了,如下所示:

ssl_protocols TLSv1.1 TLSv1.2;

当然如果你的证书支持 1.3 也可以继续添加,当时不得不说的是,禁止老版本的协议可能会导致某些意想不到的问题,就像之前子凡因为把这个协议版本修改后就导致微博不能够正常抓取网站图片,就导致微博分享图片失败的情况。

所以考虑自身实际情况,当然子凡是非常建议大家及时跟进会比较好,即使就像77生活网没有支付相关的安全需求,但是较强的配置也能够在一定层面上提升网站的安全。不过呢这样看起来比较舒服。

  • 我的微信
  • 这是我的微信扫一扫
  • weinxin
  • 我的微信公众号
  • 我的微信公众号扫一扫
  • weinxin
avatar

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: